Einleitung / Medien-Verwaltung / Bilder bearbeiten / Advanced Image Editor

Erweiterte Bildbearbeitung

Abhängig von der Konfiguration in den Projekteigenschaften, können Bilder und auch einzelne Auflösungen über die Schaltfläche Erweiterte Bildbearbeitung mit dem Advanced Image Editor bearbeitet werden.

Hinweis: Für die Nutzung des Advanced Image Editors erfolgt die Freigabe explizit „ohne Funktionsgarantie“ für die Anwendung selbst. D. h. es wird von Seiten Crownpeaks weder explizit noch implizit eine Garantie für die Funktionen der Bildbearbeitung übernommen, sondern die Nutzungsfreigabe erfolgt „as-is“. Wenn die Nutzung von Bildbearbeitungsfunktionen eine produktionskritische Funktion ist, sollte eine externe Bildbearbeitungssoftware mit dem entsprechenden Hersteller-Support verwendet werden. Unter MacOS steht der Advanced Image Editor aktuell nur sehr eingeschränkt zur Verfügung.

Erweiterte Bildbearbeitung – Advanced Image Editor

Nach einem Klick auf die Schaltfläche wird im Bearbeitungsfenster unterhalb des Ribbons der Editor mit seinen Bearbeitungsfunktionen und -werkzeugen sowie der Bilddatei zu der im Ribbon gewählten Auflösung angezeigt:

Änderungen an Bildern/Auflösungen müssen zunächst über das Icon  in die Medien-Verwaltung des SiteArchitect übernommen werden. Das Bild kann danach weiter bearbeitet werden. Final müssen die Änderungen über die Funktionen „Speichern“ bzw. „Bearbeiten beenden“ gespeichert werden.

Durch einen erneuten Klick auf die Schaltfläche Erweiterte Bearbeitung wird der Editor wieder geschlossen, nicht gespeicherte Änderungen werden nicht in FirstSpirit übernommen.

Die im Advanced Image Editor zur Verfügung stehenden Funktionen sind vergleichbar mit denen anderer einschlägiger Bildbearbeitungsprogramme.

Wichtig Einige Menüs, Tooltips und Konfigurationsdialoge (z. B. bei Filtern) können aus technischen Gründen nicht lokalisiert werden und stehen daher nur in Englisch zur Verfügung.
Wichtig Einige der in den Menüs angezeigten Tastaturkürzel funktionieren für den Editor nicht, sondern führen die bislang bekannte Funktion im SiteArchitect aus.

Werkzeugleiste

Manche Werkzeuge stellen erweiterte Konfigurationsmöglichkeiten zur Verfügung. Diese werden oberhalb des Bildes, unterhalb der Menüleiste angezeigt.

Auswahlwerkzeuge
 Über dieses Icon kann eine Auswahl bewegt oder über die Anfasser der Auswahl verformt werden.

   Über diese Icons kann ein quadratischer / rechteckiger, runder / ovaler oder ein Ausschnitt mit benutzerdefinierter Form des Bildes zur weiteren Bearbeitung ausgewählt werden. Eine solche Auswahl kann z. B. über das Menü „Bearbeiten“ angewendet, über das Menü „Auswahl“ modifiziert und über das Icon  bewegt werden. Alle Malwerkzeuge (s. u.) werden nur innerhalb einer Auswahl angewendet. Zusätzliche Funktionen stehen mit gedrückter Strg-Taste zur Verfügung.

 Über dieses Icon können zusammenhängende Bereiche ausgewählt werden, die eine gleiche oder ähnliche Farbe haben.

 Über dieses Icon kann die Farbe von Pixeln des Bildes aufgenommen werden.

Mal- und Zeichenwerkzeuge
 Über dieses Icon können aneinander grenzende Flächen mit ähnlichem Farbwert gefüllt werden.

 Mit diesem Icon kann eine hartkantige Freihandlinie gezeichnet werden.

 Mit diesem Icon können weiche Farbstriche erstellt werden.

 Mit diesem Icon kann ein definierter Bereich des Bildes dupliziert werden.

 Mit diesem Icon können Pixel des Bildes transparent gemacht werden.

  Mit diesen Icons können gerade Linien bzw. Pfeile mit definierbarer Breite und Füllmethode gezogen werden.

    Mit diesen Icons können ausgefüllte oder nicht ausgefüllte Quadrate / Rechtecke, mit eckigen oder abgerundeten Ecken, Kreise / Ovale bzw. Sterne erstellt werden.

Ansicht
 Hat das Bildfenster aufgrund der eingestellten Zoom-Stufe Scrollleisten, kann das Bild mit diesem Icon innerhalb des Fensters bewegt werden.

 Mit diesem Icon kann die Zoom-Stufe vergrößert / verkleinert (Strg) werden.

Sonstige
 Mit diesem Icon kann eine Ebene mit Text ins Bild eingefügt werden.

 Mit diesem Icon können Farbverläufe eingefügt werden.

  Mit diesen Icons kann die Perspektive des Bildes durch das Versetzen der Eckpunkte geändert oder das Bild mithilfe eines Rasters verzerrt werden.

 Über diese Icons werden die aktuelle Vorder- und Hintergrundfarbe angezeigt. Sie können über das Pfeil-Icon vertauscht werden. Über das Schwarz-Weiß-Icon kann Schwarz und Weiß als Hintergrund-/Vordergrundfarbe gewählt werden.

Menüebenen

Menü „Bearbeiten“
Über dieses Menü können Auswahlen angewendet werden: Sie können

  • ausgeschnitten (Ausschneiden)
  • kopiert (Kopie)
  • eingefügt (Einfügen)
  • gelöscht (Entfernen)

werden.

  • Existieren mehrere Ebenen übereinander, wird über Auf eine Ebene reduziert kopieren im ausgewählten Bereich eine auf eine Ebene reduzierte Kopie aller sichtbaren Ebenen erstellt.
  • Darüber hinaus können hier Bearbeitungsschritte rückgängig gemacht werden (Undo).

Menü „Ansicht“
Über dieses Menü kann die Ansicht des Bildes gesteuert werden:

  • Über die Einträge Ansicht vergrößern und Ansicht verkleinern kann das Bild abgestuft gezoomt werden.
  • Über die Einträge 1:1, 2:1, 4:1, 8:1 und 16:1 kann eine bestimmte Zoom-Stufe eingestellt werden.
  • Über den Eintrag Raster einblenden kann ein Raster über dem Bild angezeigt werden.
  • Über den Eintrag Auswahl als Maske anzeigen kann die Auswahl als Maske dargestellt werden.

Menü „Auswahl“
Über dieses Menü kann eine bestehende Auswahl modifiziert werden:

  • Alle auswählen: Wählt das gesamte Bild aus.
  • Auswahl aufheben: Hebt die Auswahl aus, so dass nichts mehr im Bild selektiert ist.
  • Umkehren: Der zuvor nicht ausgewählte Bildbereich wird ausgewählt.
  • Unscharf selektieren…: Erstellt eine Auswahl mit weichen Kanten. Der Radius kann vorgegeben werden.
  • Vergrößern: Vergrößert die Auswahl um den vorgegebenen Radius.
  • Anhand von Transparenz: Wählt alle transparenten Bereiche des Bildes aus.
  • Neue Ebene aus Auswahl: Erstellt eine Ebene auf Basis der Auswahl.

Menü „Bild“
Über dieses Menü kann das Bild insgesamt modifiziert werden:

  • Zuschneiden: Entfernt Bildteile bis auf die Auswahl.
  • Bildgröße…: Hier kann die Größe des Bildes geändert werden.
  • Horizontal / Vertikal / Diagonal spiegeln: Spiegelt das Bild horizontal / vertikal entlang der vertikalen Achse bzw. diagonal über die Querachse.
  • Drehen 90 / -90 / 180 / …: Dreht das Bild um 90° im bzw. entgegen dem Uhrzeigersinn, bzw. um 180° im Uhrzeigersinn oder um eine benutzerdefinierte Gradzahl.
  • Auswahl ausfüllen: Füllt die gesamte aktuelle Auswahl mit der gewählten Vordergrundfarbe.

Menü „Ebene“
Über dieses Menü können Ebenen angelegt, modifiziert oder gelöscht werden. Beim Beenden des Advanced Image Editors werden mehrere Ebenen zu einer zusammengefasst, beim nächsten Start steht dann nur noch diese Ebene zur Verfügung.

  • Neue Ebene / durch Kopie / durch Ausschneiden: Erzeugt eine neue leere Ebene, eine Ebene mit dem Inhalt der aktuellen Auswahl bzw. eine Ebene mit dem Inhalt der aktuellen Auswahl und entfernt die Auswahl aus der bestehenden Ebene.
  • Ebene löschen / Duplizieren: Löscht bzw. dupliziert die aktuell gewählte Ebene.
  • Umbenennen…: Mit diesem Menüeintrag kann der Name der Ebene geändert werden. Der neue Name wird beim Beenden des Editors nicht mit gespeichert und steht beim nächsten Start des Advanced Image Editors nicht mehr zur Verfügung.
  • Nach oben / Nach unten: Verschiebt die aktuelle Ebene um eine Position nach oben / unten.
  • Mit darunterliegender Ebene zusammenfassen: Fasst die aktuell ausgewählte Ebene mit der darunterliegenden zusammen.
  • Horizontal / Vertikal / Diagonal spiegeln: Spiegelt die ausgewählte Ebene horizontal / vertikal entlang der vertikalen Achse bzw. diagonal über die Querachse.
  • Drehen 90 / -90 / 180: Dreht die ausgewählte Ebene um 90° im bzw. entgegen dem Uhrzeigersinn, bzw. um 180° im Uhrzeigersinn.

Menü „Filter“
Über dieses Menü können Filter auf das Bild, die aktuelle Ebene bzw. die aktuelle Auswahl angewendet werden.

  • Letzten Filter wiederholen: Wendet den zuletzt angewendeten Filter noch einmal an.
  • Letzten Filter anzeigen: Zeigt den zuletzt angewendeten Filter bzw. den entsprechenden Konfigurationsdialog an.

Menü „Fenster“

Über dieses Menü können die Paletten auf der rechten Seite aus- bzw. eingeblendet werden.

Paletten

  • Farben: Hier kann die Vordergrundfarbe per Klick ausgewählt werden.
  • RGB-Farben: Hier kann die Vordergrundfarbe per Angabe von RGB-Werten ausgewählt werden.
  • Farbfelder („Colors“): Hier kann die Vordergrundfarbe aus einer Bibliothek ausgewählt werden. Standardmäßig wird hier eine Palette von Farben verwendet, die plattformunabhängig von allen Browsern verwendet werden können („Web-Farben“). Bei Bedarf können auch eigene Bibliotheken geladen (und später wieder abgespeichert) werden. Hochgeladene Farbbibliotheken werden beim Beenden des Editors nicht mit gespeichert und stehen beim nächsten Start des Advanced Image Editors nicht mehr zur Verfügung.
  • Farbverläufe („Gradients“): Hier kann ein Farbverlauf ausgewählt werden. Dabei können die bereits vorhandenen verwendet, bearbeitet oder eigene geladen werden. Hochgeladene oder bearbeitete Farbverläufe werden beim Beenden des Editors nicht mit gespeichert und stehen beim nächsten Start des Advanced Image Editors nicht mehr zur Verfügung.
  • Ebenen („Layers“): Hier können neue Ebenen angelegt, bearbeitet oder gelöscht werden. Siehe dazu auch Punkt „Menü Ebene“. Darüber hinaus können Füllmethoden für die aktuelle Ebene eingestellt werden. Beim Beenden des Advanced Image Editors werden mehrere Ebenen zu einer zusammengefasst, beim nächsten Start steht dann nur noch diese Ebene zur Verfügung.

© 2005 - 2024 Crownpeak Technology GmbH | Alle Rechte vorbehalten. | FirstSpirit 2024.2 | Datenschutz