Introduction
Introduction

Introduction / Technical requirements and recommendations / Compatible components

Compatible components for use with FirstSpirit

Table of contents

FirstSpirit is operated successfully by customers and partners with a wide range of different third-party components (operating systems, JDKs, servlet engines, application servers, databases).

The system configurations listed here are / have been checked by e-Spirit and deemed functional.

Information about the test interval: Compatible system configurations are tested by e-Spirit on a regular basis (depending on the market relevance of the configuration). We maintain the necessary infrastructure for common components for this purpose.

Information about troubleshooting: External components that are used in conjunction with FirstSpirit are not part of the FirstSpirit product. The relevant manufacturer (not e-Spirit) is responsible for the functionality provided by these external components.

Problems which arise when using these components in conjunction with FirstSpirit can, however, be reported via FirstSpirit product support at any time. After a detailed error analysis, e-Spirit AG will take the necessary steps to eliminate the error (or will attempt to find a workaround for the problem).

If, in individual cases, the error cannot be eliminated within FirstSpirit and a workaround cannot be found for the problem, the system configuration will be defined as "Not supported" in future.

The following factors will always help to ensure rapid troubleshooting:

  • The reproducibility of the problem and
  • An ongoing software maintenance contract with a system configuration option (if necessary including remote maintenance access to production and test systems as well as the licensing of third-party products)

FirstSpirit Server

Compatible operating systems

  • Debian GNU/Linux 9
  • Debian GNU/Linux 8
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2008
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 6
  • Suse Linux Enterprise Server 11
  • Suse Linux Enterprise Server 10
  • Ubuntu 16.04 LTS
  • Ubuntu 12.04 LTS

Important The server only supports operating systems in the 64-bit version!

Compatible JDKs

  • Oracle Java 11 (in the current version)
  • OpenJDK 14 (in the current version)
  • OpenJDK 11 (in the current version)

Important For FirstSpirit, e-Spirit supports:
  • OpenJDK: the current Java version as well as the latest LTS (Long-Term-Support) variant.
  • OracleJava: only the latest LTS (Long-Term-Support) variant.

This applies to both the FirstSpirit Server and the FirstSpirit desktop applications.

Oracle vs. OpenJDK: To reduce dependency on Oracle's Java development and also so that longer-term plans can be made for the benefit of our customers, e-Spirit will increase its focus on the use of OpenJDK. We plan to test the latest OpenJDK versions regularly for use with FirstSpirit, release them and also designate them as reference versions.

Recommended: Use of the OpenJDK distribution AdoptOpenJDK (HotSpot JVM): AdoptOpenJDK provides up-to-date OpenJDK binaries for different platforms (e.g. macOS, Linux, Windows) for download. For information about AdoptOpenJDK see https://adoptopenjdk.net

Incompatibilities with specific Java versions: FirstSpirit is always released for a main version of a JDK. JDK updates are regularly issued as part of JDK bug fixes. These updates are checked for compatibility with FirstSpirit as part of quality assurance. In very rare cases, bugs in the JDK that cannot be bypassed by programming may cause incompatibilities. These bugs are not related to FirstSpirit. In this case, we recommend switching back to an older JDK version or using a newer JDK version if available. Please contact e-Spirit Technical Support in the event of known problems.

FirstSpirit desktop apps

Compatible operating systems

  • macOS Catalina (10.15) *
  • macOS Mojave (10.14) *
  • Microsoft Windows 10
  • Microsoft Windows 8
  • Ubuntu 18.04 LTS *

* Notes on using macOS and Linux: macOS and Linux are supported but with restrictions: With these two operating systems, only the basic FirstSpirit functions are tested regularly as part of quality assurance – quality assurance continues to focus on Microsoft Windows. Linux in particular has a wide range of interfaces (window managers) which makes it very complicated to perform a full function test. Working regularly with macOS and Linux can therefore lead to more operating-system-related problems than with Microsoft Windows, but these problems are dealt with as far as is technically possible in the context of software maintenance. Due to major differences compared to Windows-based systems (particularly with regard to interface libraries), there are also restrictions in relation to drag-and-drop functions and regarding the integration of native applications, e.g., in the integrated preview.

Important Only operating systems in the 64-bit version are supported on the client side!

FirstSpirit web apps

Compatible browsers

  • Google Chrome
  • Microsoft Edge
  • Mozilla Firefox
  • Apple Safari *

* FirstSpirit works generally with Apple Safari, but there may be functional restrictions that are based on the implementation method of the browser and cannot be circumvented in programming terms (e.g. restricted SVG support).

Compatible application servers

  • Apache HTTP Server 2.4
  • Apache HTTP Server 2.2
  • Apache Tomcat 9.0 *
  • Apache Tomcat 8.5 *
  • Microsoft Internet Information Server (IIS) 8.5
  • Microsoft Internet Information Server (IIS) 8.0
  • Microsoft Internet Information Server (IIS) 7.5
  • Microsoft Internet Information Server (IIS) 7.0
  • WebSphere Application Server 8.5.5
  • WebSphere Application Server 8.5

* We strongly recommend using Apache Tomcat version 8.5.51 (or higher) or Apache Tomcat version 9.0.31 (or higher). This is because of security concerns due to critical bugs in previous Apache Tomcat versions.

Important Servlet API: A servlet engine integrating version 3.0 of the servlet API is required in order to use the FirstSpirit web applications. (Although the web applications of the FirstSpirit modules are essentially based on version 3.0, certain module features may deviate from this.)
Important The open-source product “Eclipse Jetty” which is provided with FirstSpirit is not suitable for live operation and should only be used for test purposes.

Databases

Compatible database systems

  • IBM DB2 10.5
  • IBM DB2 9.5+
  • MariaDB 10.1
  • MySQL 5.6 (Linux and Windows)
  • MySQL 5.5 (Linux and Windows)
  • Microsoft SQL Server 2016 (only for Windows Server)
  • Microsoft SQL Server 2014 (only for Windows Server)
  • Microsoft SQL Server 2012 (only for Windows Server)
  • Microsoft SQL Server 2008 (only for Windows Server)
  • Oracle 12c (Linux and Windows)
  • Oracle 11g R2 (Linux and Windows)
  • PostgreSQL 11.x (Linux and Windows)
  • PostgreSQL 10.x (Linux and Windows)
  • PostgreSQL 9.x (Linux and Windows)

Important The integrated Apache Derby database is not suitable for live operation and should only be used for tests.

© 2005 - 2020 e-Spirit AG | All rights reserved. | FirstSpirit 2020-07 | Data privacy | Imprint | Contact us