Start page
Start page

Start page

In a nutshell

The Java world is currently very complex due to modified release periods and licensing conditions (see The new Java world).

The current situation and e-Spirit's strategy regarding Java support for FirstSpirit will be explained in more detail below.

e-Spirit aims to significantly reduce the increased complexity of Java usage for its customers and partners by choosing suitable technologies for this purpose. The use of FirstSpirit should be as simple as possible for customers and partners and they should not have to concern themselves with the selection of a suitable Java Runtime Environment.

Our premise: “FirstSpirit users can concentrate fully on their tasks – e-Spirit will take care of the rest.”

The most important points of e-Spirit's strategy regarding Java usage are as follows:

  • For FirstSpirit, e-Spirit supports both the current Java version as well as the latest LTS (Long-Term-Support) variant. This applies to both the FirstSpirit Server and the FirstSpirit desktop applications.
    (History see FirstSpirit and Java)
  • Since it can no longer be assumed that Java is installed on all desktops, e-Spirit will continue to supply a continuously updated, extensively tested, and license-free Java Runtime Environment in the future, which will be used (automatically and without installation) for the FirstSpirit desktop applications.
  • As the diversity/variability in the Java environment will presumably continue to increase in the future, e-Spirit provides technology which makes it easy to change the Java environment. The Java versions which can be selected are compiled by e-Spirit.
  • The Java version can be selected based on two simple quality levels: “stable” and “experimental”. e-Spirit selects one stable version for standard use in the FirstSpirit desktop applications (→ “recommended” Java version).

© 2005 - 2020 e-Spirit AG | All rights reserved. | FirstSpirit 2020-07 | Data privacy | Imprint | Contact us